Tutorial MR3020

Hello everyone, in this tutorial I will use scripts which has been made by David Darts & Matthias Sturbel (thanks to this awesome guys!). If you have any question: arthur.pattee@clos13.net

Follow my leaves and you gonna have a wonderful, fully working piratebox🙂

First switch the button on the slide to ‘WISP‘ this step is very important!

Step 1: Connect the router to his power supply and plug it to your computer by ethernet.

Step 2: Connect yourself to 192.168.0.254 with your browser (in the URL tab), user and password are both ‘admin

Step 3: Download OpenWRT, then go to FIRMWARE&UPGRADE in the left menu, select the file that you’ve just downloaded and click on OK, wait until the router reboot.

Step 4: Download PUTTY if you are using Windows, if you’re using OSX or Linux, you will have to use the Terminal (included in your computer)
Launch an telnet connection, on 192.168.1.1, on PUTTY just select Telnet and write the IP address, or write this command in your terminal: ‘telnet 192.168.1.1

Step 5: Set your connection password for the next steps by typing ‘passwd‘, then enter your password, don’t worry if it still blank it’s totally regular.

Step 6: Edit the network configuration file by typing ‘vi /etc/config/network‘, it should looks like this:

config interface 'loopback'                                                               
        option ifname 'lo'                                                
        option proto 'static'                                                             
        option ipaddr '127.0.0.1'                                                         
        option netmask '255.0.0.0'                                                        

config interface 'lan'                                                                    
        option ifname 'eth0'                                                              
        option type 'bridge'                                                              
        option proto 'static'                                                             
        option ipaddr 'an IP distributed by your gateway router'                                                       
        option netmask '255.255.255.0'                                                    
        option gateway 'gateway router's IP'                                                     
        list dns 'gateway routeur's IP'                                                           
        list dns '8.8.8.8'

Unplug the MR3020 from your computer, and from his power supply, the plug it again to your homelan. Make sure both of your computer and your router are connected to the same network and access to internet.

Step 7: Connect youself to your router via PUTTY/Terminal in SSH to the IP you’ve set at step 6. If you’re using Terminal you have to type ‘ssh root@theIPyouveset
It will ask you a password this is the one you have choose in step 5.

Step 8: Connect a FAT32 formatted USB stick to the 3G port of the router

Step 9: Launch the installation of mkpiratebox packages by typing the following commands, you can copy-paste:

cd /tmp
opkg update && opkg install http://piratebox.aod-rpg.de/piratebox_0.6.3_all.ipk

Wait until it says: « Piratebox started, you can remove the WAN connection now »
Done! Unplug and replug your piratebox and you’re ready to share files!

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s