Tutoriel avec MR-3040 [vidéo inside]

Bonjour et bienvenu vous voici sur la page du tutoriel avec le TP-MR3040. Tous les scripts présentés, ont été développés par David Darts et Matthias Sturbel. Si vous avez des suggestions, des commentaires ou des questions, n’hésitez pas à m’envoyer un petit mail: arthur.pattee@gmail.com

Le tuto en vidéo version Mac:

Le tuto en vidéo version PC est en production

Voici la marche à suivre pour créer votre piratebox:
Pour savoir si votre routeur est un V1 ou un V2 référrez vous à l’étiquette sur la tranche inférieure de la boîte:

V2 MR3040

-Etape 1: Brancher votre routeur à son alimentation ainsi qu’à votre ordinateur via le câble éthernet fourni (note: si vous possédez le wifi sur votre ordinateur il faut le désactiver).

Note: Sur la V2, vous devez préalablement mettre le bouton sur la position WISP

-Etape 2: Connectez vous à la page de configuration du routeur avec n’importe quel navigateur en tapant dans le champ URL 192.168.0.1, L’identifiant ainsi que le mot de passe sont admin.

-Etape 3: Télécharger OpenWrt(version modifiée par Matthias Strubel pour régler les problèmes de kernel). Naviguer à travers le menu jusqu’à FIRMWARE&UPGRADE sélectionnez le fichier Openwrt que vous avez téléchargé précédemment et cliquez sur OK, attendez que le routeur redémarre.

Note: Si vous possédez un MR3040 V2 (erreur au moment de l’upgrade du firmware) voici le lien

-Etape 4: Téléchargez PUTTY (choisissez la version qui correspond à votre système), lancez le et effectuez une connexion en telnet en tapant 192.168.1.1 dans la barre nommée Host et cochez telnet (par défaut c’est SSH),

-Etape 5: Définissez un mot de passe en tapant la commande passwd

-Etape 6: Editez la configuration du routeur en tapant vi /etc/config/network
NB: L’espace entre vi et /etc est très important
NB2: pour modifier les lignes tapez i puis éditez normalement pour sauvegarder taper sur la touche escap puis ZZ éditez les lignes:

config interface 'loopback'                                                               
        option ifname 'lo'                                                                
        option proto 'static'                                                             
        option ipaddr '127.0.0.1'                                                         
        option netmask '255.0.0.0'                                                        

config interface 'lan'                                                                    
        option ifname 'eth0'                                                              
        option type 'bridge'                                                              
        option proto 'static'                                                             
        option ipaddr 'une IP comprise dans la plage de votre box'                                                       
        option netmask '255.255.255.0'                                                    
        option gateway 'IP de votre box'                                                     
        list dns 'IP de votre box'                                                           
        list dns '8.8.8.8'

-Etape 7: Connectez votre routeur à un accès internet, et allumez le/brancher le à son alimentation

-Etape 8: Connectez vous via PUTTY en renseignant dans le champ host l’IP que vous avez choisi à l’étape 6, le mot de passe est celui que vous avez défini à l’étape 5

-Etape 9: Faite un ping pour vous assurer que votre routeur est bien connecté à internet et qu’il n’y a pas de problème de configuration à l’étape 6, pour ce faire tapez:

Pour stoper le ping faite ctrl+c

ping google.com

-Etape 10: Connectez une clé USB formatée en FAT32 au port USB 3G de votre routeur

-Etape 11: Installez les packages mkpiratebox incluant le chat en tapant:

cd /tmp
opkg update && opkg install http://piratebox.aod-rpg.de/piratebox_0.6.3_all.ipk

Etape(option): Vous pouvez installer le thème Kareha permettant une personnalisation graphique plus poussée:

/opt/piratebox/bin/install_piratebox.sh /opt/piratebox/conf/piratebox.conf imageboard

Puis configurez la en tapant, pour changer le nom d’utilisateur et le mot de passe ADMIN_PASS et SECRET

vi /opt/piratebox/www/board/config.pl

-Etape 12: Si tout c’est bien passé PUTTY affiche «Piratebox started, you can remove the WAN connection now», redémarrez votre piratebox en tapant « reboot » dans la fenêtre PUTTY et voilà vous avez votre piratebox.

N’hésitez pas à l’inscrire à la carte ici.

Un soucis?

48 réflexions au sujet de « Tutoriel avec MR-3040 [vidéo inside] »

  1. Sur le MR-3040 l’URL de configuration est plutôt 192.168.0.1 pour la V1. Et il ne présente aucun bouton pour switcher entre les modes, il le fait automatiquement, à l’inverse du MR-3020

  2. bonjour,
    je viens de configurer ma piratebox, mais je bloc à l’étape 14 visiblement le port USB ne semble pas actif.
    J’ai changé de clé mais rien ne se passe. La piratebox attend une clé USB. une ligne de points se déroule.
    Pouvez-vous m’aider ?
    remarque : j’avai déjà utilisé la clé USB sur une autre piratebox que j’ai fait tombée et qui ne fonctionne plus.
    Merci d’avance pour votre aide

      • Ma clé est une sandisk de 32Go neuve formatée en FAT 32 (j’ai suivi vos conseils).
        La clé semble reconnue sur l’appareil car le voyant internet de ma MR 3040 s’allume.
        Mais au moment de l’installation le message suivant s’affiche :
        « Please connect USB disk. If it is already plugged-in,
        wait for a few seconds, and if nothing happens, please
        reconnect the device. Keep in mind that your router’s
        ports may not be able to supply enough power to
        spin-up a USB HDD.
        ……………………………… »
        J’ai testé 3 clés différentes, mais j’obtiens toujours le même message.
        J’ai revérifié tous les paramètres des étapes précédentes. Tout est conforme à votre tuto jusqu’à l’installation de la piratebox.
        Visiblement je ne suis pas le seul à qui ce PB arrive mais je n’ai pas trouvé de solution sur le web pour l’instant, et je ne suis pas assez fort en informatique pour m’en sortir seul.
        Je ne sais même pas vider le répertoire /tmp. je souhaiterais le faire pour télécharger une version « propre » du paquet car j’ai fait plusieurs téléchargement de versions différentes. Est-ce que mon PB pourrait venir du contenu de mon répertoire /tmp ? si oui – quelle(s) ligne(s) de commande me permettrait de vider ce répertoire ?

      • Hum, c’est fort possible, je vais regarder cela, ça fait un moment que je n’ai pas mis les mains dans mon terminal par manque de temps, je reviens vers vous pour une solution

  3. Juste une chose que je ne trouve pas,
    j’ai modifier ;
    find /opt/piratebox/conf/piratebox.conf

    # Uncomment line below for adding directory feature
    #DROOPY_USERDIR= » -u True  »

    par :
    # Uncomment line below for adding directory feature
    DROOPY_USERDIR= » -u True  »

    ce qui permet aux utilisateurs de choisir le répertoire ou ils veulent téléverser un fichier.

    Le problème est qu’il faut écrire le nom du répertoire, je souhaiterais savoir ou ce modifie le fichier de formulaire d’envoi (piratebox.lan:8080) pour y mettre des input déjà prédéfinis selon les répertoires que j’ai déjà sur ma PB.

    Si jamais quelqu’un a une idée de l’endroit ou se situe se formulaire ?

  4. Bonjour

    Merci pour le tutorial très clair.

    Je l’ai découvert un peu tard après avoir fait une installation en 0.5 avec un tutorial en anglais.

    J’ai quatre uestions:
    . Au moment de l’installation je n’ai pas modifié les pass du fichier config.pl et maintenant je ne trouve pas ce fichier config.pl . Je ne trouve que le fichier kahera.pl et il ne contient pas les pass : comment faire?
    . Comment upgrader de 0.5 en 0.6 ?
    . Comment mettre login et pass pour proteger acces aux fichiers ?
    . forum = chat ? J’ai un chat sur la page mais pas de forum ….

  5. bonjour
    je viens de recevoir ma MR 3040
    et j’ai suivi le tutorial suivant

    https://pirateboxfr.com/tutoriel-mr-3040/

    Mon probleme apparait à l’étape 3 pour télécharger l’image openWRT

    j’ai les messages erreurs comme quoi j’ai une V2 et je ne trouve que des images pour les V1

    voici les informations utiles

    Firmware Version:
    3.14.4 Build 121017 Rel.62268n
    Hardware Version:
    MR3040 v2 00000000

    et mon message d’erreur

    Error code: 18005
    Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name.

    Merci par avance pour ton aide

  6. bonjour

    je voudrais accéder au contenu du disque dur de la pirate box par le réseau et non par l’interface navigateur

    comment je peux faire ?

    merci

  7. Salut,
    Je viens de perdre 1h bêtement entre l’étape 6 et 7.

    1) dans l’étape 6 quand on parle de l’ip de la box il s’agit de l’ip de la box qui vous permet de vous connecter à internet (livebox, freebox, …), pas du routeur/de la piratebox… Par exemple pour ma freebox il s’agit de 192.168.0.254

    2) à la fin de l’étape 6 si ça ne fonctionne pas rebootez votre MR3040 en tapant « reboot » sous putty ou en passant par l’interface web (192.168.1.1 dans votre navigateur). Si tout se passe bien votre routeur répondra sur l’IP que vous avez indiqué dans « option ipaddr »

    3) Enfin avant l’étape 7, pour connecter le routeur à internet il faut :
    le connecter à la box de votre maison à l’aide du câble Ethernet et attendre un moment.
    se connecter en wifi à son routeur via son ordinateur
    dans le putty se connecter au routeur en spécifiant l’adresse IP de la piratebox (« option ipaddr ») et le mdp définit à l’étape 5

  8. salut je dois recevoir un mr3040 fin de semaine pour l’instant je sais pas si c’est un v1 ou v2 je serai ca qu’a la reception…mais je voulais savoir si les firmware ete tjrs ok ???? si tu l’ai avez retesté !!! j’ai aussi un mr3020 ou les 4 led ne fond que clignoté plus aucun acces…par ftdi basic et putty j’ai le terminal qui affiche toujours le meme mess toutes les secondes sans pouvoir rentrais une ligne de commande si quelqu’un a un bon tuto sur cette maniere de faire je suis prenneur

  9. Bonjour et merci pour ce tuto.
    Je suis en train de refaire une piratebox à base du MR3040.
    Mon premier était une V1.
    Le nouveau est une V2.2.
    Tout se déroule bien sauf que le wifi ne s’active pas sur le MR3040.
    Via le RJ45, en tapant 192.168.1.1 dans un navigateur, j’arrive bien sur la page d’accueil piratebox.
    J’ai édité le /etc/config/Wireless et j’ai mis la même config que celle de ma V1 et rien ne se passe non plus. Je suis certain de passer à côté de quelque chose de tout bête, mais je ne vois pas.
    Une idée ???

    • Bonjour,
      tout d’abord je remarque que vous avez fait une légère faute à la ligne /etc/config/wireless (pas de W), si vous avez fait la même faute dans votre ligne de commande sur votre routeur alors il est normal que cela ne fonctionne pas. Sinon il me faudra plus d’informations.

      • Non, je n’ai pas mis le W mais bien un w (je l’ai remarqué une fois posté…).
        En tout cas, merci de votre réponse rapide. Que voulez-vous exactement comme informations ?
        Cordialement.

  10. Bonjour,
    Tout s’est pour moi bien passé jusqu’à l’étape 6… mais n’étant pas familier de telnet j’ai mal rentré les lignes de configuration sans doute.
    Le ping montre que l’IP de mon MR-3040 est toujours 192.168.1.1
    J’essaye de me connecter à nouveau par putty/telnet/192.168.1.1, mais c’est impossible : putty se ferme.
    Par putty/SSH/192.168.1.1 j’accède à un écran noir, mais je ne sais pas trop que saisir.
    Comment puis-je revenir au début de l’étape 6 pour rattraper mes erreurs ?
    Merci de votre aide.

    • Vous pouvez tenter un accès en failsafe, comme ceci:
      « Failsafe Mode
      Switch on the router
      Wait almost 5 sec
      Press the « Reset » for ~3sec
      The device is now in Failsafe-Mode
      You may access it by using telnet 192.168.1.1/24 or serial
      Keep in mind: The LEDs won’t flash in Failsafe Mode! »
      Ensuite changer l’adresse IP de votre routeur, débranchez le et recommencez à l’étape 6🙂

      • Merci de la rapidité de votre réponse.
        J’ai effectué les opérations que vous me conseillez… mais ça ne fonctionne toujours pas.
        Voici quelques observations : mon MR3040 branché sur on ordi en ethernet dialoguent.
        Un ping vers le MR3040 depuis l’ordi fonctionne sans problème, confirmant que l’IP du routeur est bien 192.168.1.1
        Quand je tente une connection telnet depuis Putty sur 192.168.1.1, Putty affiche : Network error: Connection refused (et cela en ports 22, 23, ou 24).
        Que faire ?
        Merci !

      • Je reviens sur mon message précédent, après lequel j’ai tenté une connexion en SSL… et je suis rentré dans le routeur. Me revoilà donc au début de l’étape 6, que je vais cette fois tenter de réussir. Merci de votre aide aux novices, je vous tiens au courant.

      • Après quelques tätonnements, ça tourne, rien de bien sorcier si on suit correctement les indications.
        Quelques lectures préalables sur les commandes Putty utiles pour les débutants tout de même, sous peine de ferrailler dans l’écran noir
        Mes transferts sont cependant bien lents, peut-être est-ce dû à la clef (une IT-works qui prenait la poussière sur mon bureau), peut-être devrais-je la changer, qu’en pensez-vous ?

      • Je note, peut être ferais-je un mini tuto sur PUTTY prochainement alors🙂
        Je pense que c’est malheureusement le cas, pour en changer veillez a copier les fichiers présents sur l’actuelle clé afin de les copier sur la nouvelle

      • “veillez a copier les fichiers présents sur l’actuelle clé afin de les copier sur la nouvelle” : c’est tout ce qu’il y a à faire pour changer de clef ?

  11. Bonsoir !

    Merci pour le travail et les tutos. Voilà, je suis comme Bernard 9 mars 2014 à 012 09

    Je n’ai plus accès au routeur et tous les pings fail.
    Request timeout for icmp_seq 0 …
    et le telnet et ssh tout pareil avec des hosts qui repondent pas.

    J’ai aussi essayé par failsafe rien n’y fait.

    J’crois qu’y a eu un problème lors de l’installation des fichiers sur l’usb, tout avant fonctionnait parfaitement.
    Si Bernard me lit, comment avez-vous établi une connection ssl ?
    Ou si vous avez une idée, ou un tuto pour remettre le firmware d’origine sur le 3040, car je n’ai aucune idée comment faire, je ne connais pas les lignes de commande terminal qui pourraient le faire.

    Merci beaucoup

  12. Bonjour, c’est Bernard qui parle😉
    Toutes mes tentatives, plus ou moins équilibristes, pour remettre le firmware d’origine ont échoué… j’ai donc changé de stratégie et cherché à rentrer dans le système en telnet puis en ssh. Les choses sont déjà anciennes (2 semaines) et j’ai malheureusement un peu oublié comment je m’en suis tiré. Moi non plus je ne pinguais pas, j’ai essayé plusieurs IP avant de rentrer dans le routeur (l’adresse IP du routeur avait changé). Je précise que je n’y connais pas grand chose dans ce domaine, mais j’ai réusssi : donc c’est possible…
    La PB fonctionnait à peu près correctement (bien que très lentement), j’ai donc vite eu envie de migrer en LibraryBox. Bien m’en a pris, j’ai trouvé la LB plus rapide, et aussi plus simple à remplir de documents à proposer en téléchargement.
    Pour l’install, problème similaire (plus de firmware d’origine) , mais solution plus simple, puisqu’on peut appliquer la solution de mise à jour bien décrite ici :
    http://jasongriffey.net/librarybox/upgrading.php
    Dans ton cas, il est sans doute possible de charger directement le firmware LibraryBox 2.0 et tu seras tiré d’affaire.
    Le noeud de ton problème, c’est donc de récupérer d’une façon ou d’une autre l’IP de ton routeur. Après, tu seras sauvé !
    Bon courage🙂

    • Merci Bernard.

      Toujours fanny mais je persiste. Je viens de découvrir des outils comme nmap.
      Bonne nouvelle d’apres nmap 192.168.1.1 host is up, avec port 22 bloque ssh, mais le terminal me donne un ping qui fait chou blanc, pareil pour le telnet ou ssh.
      Je vais prendre la piste nmap voir si il y a des hacks en commande terminal nmap pour reuploader soit wrt soit le firmware original.
      Si quelqu’un a des idées ou eu la meme expérience…

      Bonne journée

      • Déterrage de sujet, je réagis par rapport au dernier commentaire laissé fin mars… Je suis exactement dans le même cas de figure, je serai intéresser de savoir s’il est possible à partir de nmap de restaurer le firmware d’origine…

        J’ai le MR3040 v2, je n’ai pas fait de PB, mais j’avais flashé le firmware pour installer DD server et utiliser l’app dslr dashboard. Comme elle ne tourne pas terrible avec mon appareil photo, j’ai voulu en tester une autre (dslr controller) qui nécessite un re-flashage de firmware et de repasser par celui de TP Link. J’ai plus ou moins réussi, j’arrive à me logger sous la page du server TP Link, mais les frame de gauche et du centre sont vides, seuls sont documentés le frame supérieur et le frame droit (et bien sur toutes les options de menu sont dans le frame gauche). Je pense que j’ai utilisé la mauvaise version de firmware TP link pour la V2 (la TL-MR3040_V2_131121)

        Bref, je veux faire une réinstallation clean mais impossible d’y accéder au routeur via Putty, SSH ou Telnet😦

        Si la solution nmap a fonctionné, je serai intéressé pour connaitre le détail des opérations…

        merci!

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s