Mise à jour piratebox

Vous avez installez votre piratebox et vous voulez la mettre à jour?

Connecter votre routeur directement à votre PC et connecter en telnet ou en SSH. Tapez ceci:

vi /etc/config/network

Modifiez l’option ipaddr comme ceci

config interface 'loopback'                                                               
        option ifname 'lo'                                                                
        option proto 'static'                                                             
        option ipaddr '127.0.0.1'                                                         
        option netmask '255.0.0.0'                                                        

config interface 'lan'                                                                    
        option ifname 'eth0'                                                              
        option type 'bridge'                                                              
        option proto 'static'                                                             
        option ipaddr '192.168.0.34'                                                       
        option netmask '255.255.255.0'                                                    
        option gateway '192.168.0.254'                                                     
        list dns '192.168.0.254'                                                           
        list dns '8.8.8.8'

Appuyez sur echap puis ALT+ZZ et tapez exit. Connectez votre routeur à internet et connectez vous en SSH ou en telnet à l’adresse « 192.168.0.16 », logez vous et tapez la commande:

/etc/init.d/piratebox stop
opkg remove piratebox
cd /tmp
opkg update && opkg install http://piratebox.aod-rpg.de/piratebox_0.6.3_all.ipk

4 réflexions au sujet de « Mise à jour piratebox »

    • En effet sur mon tutoriel je spécifie 192.168.0.254, seuleument cette adresse dépend de votre infrastructure réseau. Cette adresse correspond en effet à celle de votre box sur votre réseau local. Je modifie cela pour que ça soit plus clair

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s